Autor Tema: Problema con líneas entre TILES  (Leído 209 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado tomisosa11

  • Visitante
  • *
  • Puntos: 10
  • Mensajes: 4
    • Ver Perfil
Problema con líneas entre TILES
« en: Mayo 16, 2017, 08:26:05 am »
Hola a todos, soy nuevo en esta comunidad, y me cree la cuenta para que me puedan resolver ésto  XD

Bueno, mi problema consiste en que tengo un juego de carreras, el cual una vez bastante avanzado, me decidí en crearle un Menú principal. La cosa es que cuando inicio el juego con el menú principal antes que el del juego en los Backgrounds, y luego hago click en Empezar juego (Le hice un botón que cambie de background y que te lleve al juego), el juego comienza normalmente, excepto por el fondo, que entre los cuadrados de los tiles (64x64), hay líneas blancas y negras. En cambio, cuando, sin cambiar nada excepto la ubicación de los Backgrounds (pongo primero el del juego), el juego comienza normalmente sin las líneas blancas. Es más, he hecho un botón que cuando presiones escape te lleve al Background del Menú principal, y cuando toco Empezar juego, el juego comienza normalmente sin las líneas blancas.


En resumen
Cuando le doy a Empezar juego de primera, el juego me muestra líneas blancas. Cuando comienzo el juego directamente, sin el menú, el juego no las muestra.
¿Alguien sabe por qué será?

PD: Probé borrando algunos cuadros del tile en el fondo del juego para ver si el fondo se seguía viendo y no se veía, es decir, aparecía el fondo gris. Es más, probé quitando el fondo del juego y en donde no hay tiles (los que eliminé), se ve negro, y las líneas siguen siendo blancas.
Desde ya, ¡gracias!
  :D

Les dejo la foto para que vean cómo se ve
« última modificación: Mayo 16, 2017, 05:53:19 pm por tomisosa11 »


 
No Tienes Permisos Para Dar Puntos
point 0 Puntos

Este tema no recibió puntos.


Desconectado somnus

Re:Problema con líneas entre TILES
« Respuesta #1 en: Mayo 16, 2017, 06:07:08 pm »
a mi en lo personal nunca me ha pasado eso, intent checar bien la resolucion d etus tiles y asegurate que no tengan lineas blancas, tambien intent cambiar interpolate colors en general settings.
Es Mejor No Saber Porque Funciona, Que Saber El Porque No Funciona...
 


Desconectado tomisosa11

  • Visitante
  • *
  • Puntos: 10
  • Mensajes: 4
    • Ver Perfil
Re:Problema con líneas entre TILES
« Respuesta #2 en: Mayo 17, 2017, 06:25:50 am »
a mi en lo personal nunca me ha pasado eso, intent checar bien la resolucion d etus tiles y asegurate que no tengan lineas blancas, tambien intent cambiar interpolate colors en general settings.

MUCHÍSIMAS GRACIAS!!!

Te agradezco por ser el único que se molestó en responder :D Y también te agradezco porque me funcionó tu respuesta!!! Los tiles están perfectos porque los hice yo uno por uno y no tienen líneas blancas entre medio. Lo que sí hice, fue buscar donde estaba "Interpolate Colors" (Global Game Settings -> Windows -> Graphics) y desactivé esa opción. Y ¡voilá! funcionó :)
 

Desconectado tomisosa11

  • Visitante
  • *
  • Puntos: 10
  • Mensajes: 4
    • Ver Perfil
Re:Problema con líneas entre TILES
« Respuesta #3 en: Mayo 17, 2017, 08:59:24 am »
a mi en lo personal nunca me ha pasado eso, intent checar bien la resolucion d etus tiles y asegurate que no tengan lineas blancas, tambien intent cambiar interpolate colors en general settings.

MUCHÍSIMAS GRACIAS!!!

Te agradezco por ser el único que se molestó en responder :D Y también te agradezco porque me funcionó tu respuesta!!! Los tiles están perfectos porque los hice yo uno por uno y no tienen líneas blancas entre medio. Lo que sí hice, fue buscar donde estaba "Interpolate Colors" (Global Game Settings -> Windows -> Graphics) y desactivé esa opción. Y ¡voilá! funcionó :)

El único problema con todo esto, fue que la calidad de mi imagen bajó muchísimo, es decir, cada vez que el auto rota, se ven los pixeles exteriores "surfeando" por los pixeles interiores (no sé si tendrá nombre eso jajaja) pero al fin y al cabo "solucioné" el problema principal. Lo único que me quedaría resolver, es el problema XD

Luego voy a probar con otros fondos a ver que tal. Si alguien sabe cómo solucionarlo, me lo dice por favor? Gracias!
 

Desconectado Clamud

Re:Problema con líneas entre TILES
« Respuesta #4 en: Mayo 19, 2017, 02:32:39 am »
Este problema es muy común, se explica aquí: https://www.yoyogames.com/blog/3
Para solucionarlo se debe agregar un "buffer" alrededor de cada tile, este programa puede ayudar: http://gmc.yoyogames.com/index.php?showtopic=546371
 

Desconectado tomisosa11

  • Visitante
  • *
  • Puntos: 10
  • Mensajes: 4
    • Ver Perfil
Re:Problema con líneas entre TILES
« Respuesta #5 en: Mayo 19, 2017, 08:14:03 pm »
Este problema es muy común, se explica aquí: https://www.yoyogames.com/blog/3
Para solucionarlo se debe agregar un "buffer" alrededor de cada tile, este programa puede ayudar: http://gmc.yoyogames.com/index.php?showtopic=546371

AL FIN UNA SOLUCIÓN!!!

Muchas gracias bro, de verdad :D Aunque tuve que hacer toda la pista de nuevo, apenas se notan las líneas esas y ya no son blancas sino de la misma textura de la calle :) Gracias por la ayuda!