Noticias

Se ha publicado un nuevo servicio, el Portal de Juegos Online

Comunidad Game Maker

Bienvenid@ a la comunidad hispana de Game Maker. Nuestro objetivo es crear videojuegos y dar soporte en castellano de GM. Para mejorar nuestro servicio hemos implantado, como adicion al reglamento general, algunas normas especificas en los subforos más comunes. ¡No olvides informarte antes de participar!.

Autor Tema: Error Raro con los Scripts  (Leído 336 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado arcangelcaos

en: Diciembre 26, 2015, 06:01:38 pm
Hola otra vez.

Tengo varios script del tipo  CrearPaths(), y cosas por el estilo, y dentro hacen varias cosas.
No me funcionan bien, es muy raro, les tengo puesto interceptores, F9, para para los valores que cogen y como lo hace, y nada. No se para en los interceptores, por más que ponga, no se para en ninguno.

También se supone que llamo a un scripts, pero esto no llega a ejecutarse nunca, es muy raro raro raro.

Alguno le ha pasado?????

 


No Tienes Permisos Para Dar Puntos
point 0 Puntos

Este tema no recibió puntos.


Desconectado jmbs19

  • Asiduo
  • *
  • Puntos: 252
  • Mensajes: 216
  • Sexo: Masculino
    • Ver Perfil
    • YGE Productions
Respuesta #1 en: Diciembre 26, 2015, 07:20:08 pm
veo dificil que te podamos ayudar sin informacion concreta.

el problema no esta bien explicado, lo que te entendi es que creas un path pero despues quieres detenerlo pero no se detiene.

eso pueden ser muchas cosas, que no estes deteniendo el path correctamente, que tus condicionales esten mal planteados, que no llames adecuadamente el script, como te digo, no podemos hacer mucho con la informacion que nos diste.

de todas maneras te dejo el link al manual de los path.
http://docs.yoyogames.com/source/dadiospice/002_reference/paths/

no puedo creer que me hice un tumblr.
YGE Productions yep, otro tumblr.
y como no, el manual tambien
 


Desconectado arcangelcaos

Respuesta #2 en: Diciembre 26, 2015, 07:49:48 pm
No, no es eso. Creo k no me entendistes.
Es que no me ejecuta bien los scripts. Que cuando hago la llamada desde cualquier sitio, ScrAndarEnemigo(argument0,argument1) no me los ejecuta bien. Por mas interceptores que le ponga "F9", no se para, se los salta y para donde le da la gana. Le doy a f10 para que vaya poco a poco y se salta todo de golpe. Es rarísimo

 


Desconectado bygdle

  • Flota de Justicia Particular.
  • Moderadores globales
  • Okupa
  • *
  • Puntos: 2841
  • Mensajes: 1.715
  • Agradecido: 150 veces
  • Sexo: Masculino
  • Thomas the dank engine.
    • Ver Perfil
Respuesta #3 en: Diciembre 26, 2015, 08:02:00 pm
Al parecer sólo estás intentando contar tus experiencias, porque no veo mucha cooperación para intentar solucionar tu problema :-[

Recuerda que no leemos mentes ni somos adivinos, así que algo más de información no es dañina.... XD

alaberga regué el café.

BA:STFW&RTFM
 


Desconectado jmbs19

  • Asiduo
  • *
  • Puntos: 252
  • Mensajes: 216
  • Sexo: Masculino
    • Ver Perfil
    • YGE Productions
Respuesta #4 en: Diciembre 26, 2015, 08:38:13 pm
pues sigo sin entederte amigo, porfavor explicate bien.

¿cuando haces una llamada a un script este no se ejecuta? pues pueden ser muchas cosas, las que ya te dije por ejemplo. incluso puede que tu script no este bien hecho, tu esperas que aga algo pero no lo hace porque no esta bien hecho, yo solo digo que sin informacion concreta no podemos hacer nada mas que especular.

no puedo creer que me hice un tumblr.
YGE Productions yep, otro tumblr.
y como no, el manual tambien
 


Desconectado Guacusio

Respuesta #5 en: Diciembre 26, 2015, 09:55:14 pm
¿Comprobaste que realmente el script no se ejecuta nunca? (que no haga nada no significa necesariamente que no se esté ejecutando). Al comienzo del script coloca una sentencia que obligue al juego a pausarse, como mostrar un mensaje con show_message; así sabrás si realmente el script se ejecuta o no.

También debieras aclarar si con interceptores te refieres a breakpoints que detienen el juego en modo debug.


 


Desconectado arcangelcaos

Respuesta #6 en: Diciembre 26, 2015, 10:59:48 pm
¿Comprobaste que realmente el script no se ejecuta nunca? (que no haga nada no significa necesariamente que no se esté ejecutando). Al comienzo del script coloca una sentencia que obligue al juego a pausarse, como mostrar un mensaje con show_message; así sabrás si realmente el script se ejecuta o no.

También debieras aclarar si con interceptores te refieres a breakpoints que detienen el juego en modo debug.

Gracias, a eso me referia, a los breakpoints en modo debug, no se para en casi ninguno, o se para donde le da la gana.

Bueno, al final, movi de sitio el proyecto, lo importe, lo duplique, borre, cree otra vez, y mil cosa, y ya funciona bien.
Alguna cosa se había quedado pillada, no se.

Gracias a todos por responder