Noticias

Importante: ¡Si quieres publicar tu juego no olvides leer este tema!

* Sponsor

Comunidad Game Maker

Bienvenid@ a la comunidad hispana de Game Maker. Nuestro objetivo es crear videojuegos y dar soporte en castellano de GM. Para mejorar nuestro servicio hemos implantado, como adicion al reglamento general, algunas normas especificas en los subforos más comunes. ¡No olvides informarte antes de participar!.

Autor Tema: problema con musica  (Leído 2792 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado selcare

  • Visitante
  • *
  • Puntos: 14
  • Mensajes: 8
    • Ver Perfil
en: Julio 14, 2014, 05:53:38 am
perdón pero me acabo de cambiar a gamemaker studio... y no se por que rayos no me acepta la musica de fondo. ya la cambie a distintos formatos y no me la reconoce al ejecutar el juego.  cuando le doy probar sonido se escucha correctamente. el problema es cuando ejecuto el juego solo se escuchan los efectos pero la música que pongo de fondo nada de nada. alguien me puede decir que rayos hago mal.
acaso tengo que haser algo especial a la musica para que se escuche

 


No Tienes Permisos Para Dar Puntos
point 0 Puntos

Este tema no recibió puntos.


Desconectado penumbra

Respuesta #1 en: Julio 14, 2014, 05:59:34 am
¿Qué funciones usas? Con los datos que das es difícil saber qué pasa. Ya no se debería (se puede) usar las funciones de audio "antiguas" que se usaban en GM8.x. El sistema de audio es nuevo en GM:S y usa funciones nuevas. Aun así GM:S da la opción de usar el sistema de audio viejo, (las viejas funciones), pero para esto debes desactivar el nuevo sistema de audio en la configuración global del juego

 


Desconectado selcare

  • Visitante
  • *
  • Puntos: 14
  • Mensajes: 8
    • Ver Perfil
Respuesta #2 en: Julio 14, 2014, 06:20:17 am
ohh si bueno  yo solo conosco estas funciones  sound_play() y sound_loop() la musica solo me funcionan cuando pruebo el juego en html5

ahun desconosco muchas cosas de esta vercion. los manuales no son muy claros. almenos no para mi


en settings del mapa CREation code. escribo.  sound_loop(music)
y no funciona en absoluto. solo con los efectos de sonido.
« Última modificación: Julio 14, 2014, 06:23:22 am por selcare »

 


Desconectado zorge

Respuesta #3 en: Julio 14, 2014, 12:34:44 pm
prueba con audio_play veras que con eso te funciona :)

 


Desconectado selcare

  • Visitante
  • *
  • Puntos: 14
  • Mensajes: 8
    • Ver Perfil
Respuesta #4 en: Julio 14, 2014, 05:47:37 pm
prueba con audio_play veras que con eso te funciona :)

Genial era algo mas sencillo de lo que esperaba, eso pasa por no informarme con mas calma. muchas gracias zorge  has salvado mi proyecto.

 


Desconectado 7sixerCF

Respuesta #5 en: Julio 14, 2014, 06:01:19 pm
Puedes actualizar tu GMS en la versión 1.3 los audios no son ni de fondo ni efectos se ordenan meramente por prioridad pero todos se manejan igual por lo tanto es mas facil utilizarlos.